mbz stalls

Other
Tutor: None Selected Time limit: 3 Days

my 93 mercedes 400E runs great then suudenly starts missing and stalls out. after about 20 minutes to 1 hr., it starts right up and runs great again as if nothing happened. i've been told it's an ignition module that costsm about $3,000. could this be???

Oct 3rd, 2013
Your cruise control is effectuated through your Electronic Throttle Actuator (ETA). I had a 93 400E where the cruise control stopped working and it turned out to be a bad ETA cable (they used the same bogus wiring on the ETA as on the wiring harness). The insulation on the wires inside the ETA cable crumbles and the wires short out. I discovered this by accident because I moved the ETA cable slightly and noticed the cruise control started working again.

Another function of the ETA is Idle Speed Control. I would start with the ETA and cable. Also, if the upper engine wiring harness is original, it probably needs to be replaced. On the 92 model, you probably have the 90 degree angle connector for the ETA. I think they went to a straight connector in late 93 or early 94. Mercedes sells the cable for the old style and, if you are good at soldering, you can change the cable yourself. You have to special order the cable. Most dealers don't carry the part.


You can have the ETA rebuilt with a 2-year warranty for about $275 through Don Roden Electronics in AL. The wiring harness can be purchased for around $500-600 and it doesn't take more than about an hour or two to install with no special tools. If you are planning to keep the car and the wiring harness is original, I would definitely change that. Usually the ETA's with ASR are more problematic. I don't know if your car had that option. My old 93 400E did not, but the harness for the ETA was still toast.

By the way, I accidentally discovered my ETA cable was bad when I was looking under the hood with the ignition on and the engine off. I was trying to figure out why my cruise control had stopped working. I was leaning on top of the air filter housing and it pressed down onto the bad ETA cable and caused the ETA motor to actuate. I discovered that every time I pushed on the housing the electric motor would run. Eventually I traced it back to the ETA cable underneath. Then I realized that I could get my cruise control to work, or stop working, by moving the cable in different positions.

The ETA is not hard to remove. It sits right under the mass air flow sensor or LH (hot wire) as Mercedes calls it. You will likely have to replace the hardened hose that goes from the back of the passenger side valve cover across the engine to the ETA. It comes in sections and it is difficult to replace just one section without breaking the next. You will see what I am talking about once you get the air filter housing off. \
The hose is #29 in the diagram
http://www.w124-zone.com/downloads/MB%20CD/W124/w124CD1/Program/Engine/119/30-1262E.pdf

You can change the wiring harness on the 400E in the parking lot in about an hour. It is really easy. You have to take the air filter housing off and you will see it. The hardest part is where the lever-type rectangular plug goes through the hole in the firewall towards the back passenger side of the engine compartment, but that's not even too bad.

All you need is an Allen wrench set and a screw driver. If I recall correctly, there are 8 fuel injection plugs, a plug for the mass air flow sensor, one for each cam sensor on the front of the engine, one for the coolant temperature sensor on the front intake manifold and maybe one or two others. It is really intuitive once you lay the new harness along the old one.


Source
http://www.peachparts.com/shopforum/tech-help/330653-400e-rough-start-idle-when-cold.html
Oct 5th, 2013

Are you studying on the go? Check out our FREE app and post questions on the fly!
Download on the
App Store
...
Oct 3rd, 2013
...
Oct 3rd, 2013
Dec 8th, 2016
check_circle
Mark as Final Answer
check_circle
Unmark as Final Answer
check_circle
Final Answer

Secure Information

Content will be erased after question is completed.

check_circle
Final Answer