plymout laser 1990

Other
Tutor: None Selected Time limit: 1 Day

i have flashed computer but on a new crank shaft sensor it still wont fire..dont know what eles to do...help  please  

Oct 13th, 2013
is there any spark?
Yes, ignition is working
No, Double check the crank shaft sensor connector and make sure it is connected properly. Check the ignitor is working properly, check distributor.

Check air mass sensor and throttle positioning sensor. This applies ONLY if there is spark.

If all of the above are okay, did someone remove the distributor? Was the distributor installed in the same orientation as when it was taken out?
Oct 14th, 2013

isnition is turn over and over   no spark at all...would two coil packs go at once...has no distributor just a crank shaft sensor.. 2.0 twin cams..no turbo...90 plymouth laser  rs  w/o turbo...got any more ideas

Oct 14th, 2013

Hi,

It is pretty much crank sensor or two coil packs, but I would have the crank positioning sensor checked first, before investing any money on the coil packs. If there is an autozone in your area, they are offering FREE crank positioning sensor testing.

Oct 14th, 2013

Are you studying on the go? Check out our FREE app and post questions on the fly!
Download on the
App Store
...
Oct 13th, 2013
...
Oct 13th, 2013
Dec 6th, 2016
check_circle
Mark as Final Answer
check_circle
Unmark as Final Answer
check_circle
Final Answer

Secure Information

Content will be erased after question is completed.

check_circle
Final Answer