Time remaining:
F-450 automatic trans

Other
Tutor: None Selected Time limit: 0 Hours

I have a 2008 F-450 wrecker with the 6.4 turbo and automatic.  I come in the other afternoon and parked it having no problems out of it.  Cranked it up that night and it would not move when I put it into drive.  I tried reverse and it moved about a foot or two.  I then put it into drive again and still nothing in any forward gears.  When I put it back into reverse I had nothing.  I have checked the fluid level, look for broken or damaged wires or connectors and checked for any other leaks or damage to the transmission and found nothing.  No codes are coming up but the mechanic said something about it not showing to be in gear while the shifter is.  I pull into our lot realy slow because there is a dip.  I then go over a small hump then park.  I had a solid low rear and high gears before I put it into park and shut it off.  Any ideas what this could be?

Nov 18th, 2013
Hi,

Tell your mechanic to check the shifter linkage, shift lever, selector cable. Transmission problems does not happened overnight. You should be experiencing something like slipping for a day or more before it will finally give up.
Nov 19th, 2013

Did you know? You can earn $20 for every friend you invite to Studypool!
Click here to
Refer a Friend
...
Nov 18th, 2013
...
Nov 18th, 2013
Feb 20th, 2017
check_circle
Mark as Final Answer
check_circle
Unmark as Final Answer
check_circle
Final Answer

Secure Information

Content will be erased after question is completed.

check_circle
Final Answer