2001 olds intrigue

SoccerBoss
Category:
Other
Price: $5 USD

Question description

I have a 2001 Olds intrigue. It ran perfect for the 1st few days after I bought it. On about the 4th day the engine light came on and it was tugging to get up hills. It would also jump and feel like I pressed the brake when I got past 55 mph. It then wouldn't go past 40 mph at all. I took it to a transmission shop and they said it was the catelitic convertor. I bought a new on and had it professionally installed. I was running good for the first few miles and started doing the same thing only past 55mph. It then felt like it stalled the next day in a parking lot. The power steering didn't work but the battery light didn't come on like it would if it would had completely stalled. The code that had came up were mass air flow, o2 sensor, CAT, and misfire. The o2 sensor and the catelitic convertor have been replaced. Do you have any idea what else I could do to make my car better. I was told by friends that its just a tune up and a vacuum hose.

Studypool has helped 1,244,100 students
Ask your homework questions. Receive quality answers!

Type your question here (or upload an image)

1823 tutors are online

Related Other questions

03/25/2015
12/23/2013
12/16/2013
12/16/2013
12/16/2013

Brown University





1271 Tutors

California Institute of Technology




2131 Tutors

Carnegie Mellon University




982 Tutors

Columbia University





1256 Tutors

Dartmouth University





2113 Tutors

Emory University





2279 Tutors

Harvard University





599 Tutors

Massachusetts Institute of Technology



2319 Tutors

New York University





1645 Tutors

Notre Dam University





1911 Tutors

Oklahoma University





2122 Tutors

Pennsylvania State University





932 Tutors

Princeton University





1211 Tutors

Stanford University





983 Tutors

University of California





1282 Tutors

Oxford University





123 Tutors

Yale University





2325 Tutors